Intel ontdekt bug in AMD's Spectre V2-patch

32 reacties

Eerder deze week kwam het nieuws van een nieuw Spectre-beveiligingslek naar buiten. Processors van Intel en Arm zijn kwetsbaar voor deze variant, maar AMD-gebruikers hoefde zich geen zorgen te maken. Intels research team STORM heeft nu ontdekt dat AMD's patch voor een eerdere Spectre-variant, Spectre V2, onvoldoende bescherming biedt.

AMD heeft nieuwe instructies voor de bestrijding van Spectre V2 gepubliceerd, wat Intels ontdekking bevestigt. In de instructies verwijst AMD naar alternatieve patches; de door AMD eerder gebruikte "LFENCE/JMP"-methode kan hiermee als ineffectief worden gezien. AMD vermeldt niet op de hoogte te zijn van op dit moment actieve 'exploits' voor zijn producten.

Het Spectre-beveiligingslek werd in 2018 ontdekt, samen met het vergelijkbare Meltdown. Malware kan door misbruik te maken van voorspellende functies, aanwezig in vrijwel elke moderne processor, het geheugen van andere processen uitlezen, met alle gevolgen van dien.

Bronnen: AMD, Tom's Hardware

« Vorig bericht Volgend bericht »
0