PlayStation 5-controllers kunnen nu ook gebruikt worden op Linux

5 reacties

Vanmiddag schreven we over PlayStation 5-controllers waar in sommige gevallen de adaptive triggers niet naar behoren functioneren. Gelukkig is er ook positief nieuws, want de DualSense-controller heeft inmiddels ondersteuning voor Linux.

Dat schrijft Phoronix, die de driver in kwestie in de Linux Input Mailing list heeft gevonden. Sony-ontwikkelaar Roderick Colenbrander schrijft dat de software nog niet alle functies ondersteunt, maar wel de meeste. Daaronder verstaan we de verbindingsmogelijkheden via zowel Bluetooth als via de usb-aansluiting, de ledverlichting, het touchpad, de bewegingssensoren en de trilmotoren.

De Linux-kernel heeft al ondersteuning voor een driver die we kennen onder de naam 'hid-sony' (van human input device), maar de PlayStation 5-controller maakt gebruik van een andere driver genaamd 'hid-playstation'. Klaarblijkelijk is het doel om bepaalde Sony-hardware die nu nog gebruikmaakt van de hid-sony-driver te voorzien van de hid-playstation-driver, vermoedelijk om het onderhoud aan de software te vergemakkelijken. In ieder geval moet de PS5-controller de overstap maken. Wel moet de hid-sony-driver in gebruik blijven voor andere hardware. Een jaar geleden maakte Sony bekend dat het de hid-sony-driver officieel zelf ging onderhouden.

Er zijn helaas nog wel functies die niet ondersteund worden, zoals de adaptive triggers die eerder vandaag hardwarematige problemen hadden. Ook op voice coils gebaseerde haptische feedback blijkt nog niet ondersteund te zijn. Dat moet komen omdat deze functionaliteit een complexe en grote hoeveelheid data vereist, waar de huidige gebruikte frameworks niet geschikt voor waren. Sony's ontwikkelaar zegt nog te onderzoeken hoe deze functies kunnen worden toegevoegd. De dertien patches zijn te zien in de Linux Input Mailing List.

Bronnen: Phoronix, Linux Input Mailing List, (patches)

« Vorig bericht Volgend bericht »
0
*