Apple blokkeert Unc0ver-jailbreak met iOS 13.5.1, nog geen fix voor oudere modellen

3 reacties

Apple heeft met iOS 13.5.1 een patch doorgevoerd waarmee de recent uitgebrachte Unc0ver-jailbreak weer onmogelijk wordt. De jailbreak maakte gebruik van een zeroday, maar schijnbaar was die al bekend bij Apple. Voor oudere modellen die geen iOS 13 ondersteunen is er nog geen update.

Geheugenlek gerepareerd

Dat de mogelijkheid tot jailbreaken ongedaan gemaakt is wordt niet aan de grote klok gehangen. Zo noemt Apple het nergens in de changelog van iOS/iPadOS 13.5.1. Op een aparte supportpagina wordt het echter wel bevestigd. Het gaat om de kwetsbaarheid CVE-2020-9859, die volgens Apple een "memory consumption issue" is. Hierdoor was het mogelijk om code uit te voeren met kernel privileges.

iOS 13.5.1 komt slechts een week nadat de jailbreak gepubliceerd werd, waardoor het vermoeden rijst dat Apple al op de hoogte was van de gebruikte kwetsbaarheid. Voor apparaten die iOS 13 ondersteunen lijkt het hiermee opgelost.

Nog geen fix voor oudere modellen

De jailbreak werkt echter vanaf iOS 11. Voor apparaten die geen iOS 13 ondersteunen is er nog geen update beschikbaar. Het is onduidelijk of die wel in de maak is. Recent werd wel iOS 12.4.7 uitgebracht met beveiligingsupdates, maar de patch voor deze kwetsbaarheid is daarbij niet inbegrepen. Hierbij gaat het om de volgende modellen: iPhone 5s, iPhone 6, iPhone 6 Plus, iPad Air, iPad mini 2, iPad mini 3 en iPod touch 6th generation.

Bronnen: Security Content iOS 13.5.1, Security Content iOS 12.4.7, CVE-2020-9859

« Vorig bericht Volgend bericht »
0
*