Samsung series 5 ultrabook stuck into bios booting loop.

Today I bought a Samsung series 5 ultra book at a thrift store. it still looks like its in mint condition. The only problem it has is that it is keeping on rebooting on the bios. I have tried a lot of possible solutions. I can not reach the bios menu.

Things i have tried already:

  • Reseat the ram
  • Boot without hard drive
  • Boot with different hard drive
  • Reset the Cmos with unplugging the battery
  • Booting with hard drive disconnected
  • Holding the power button for 30-40 seconds

I have no idea what else i can try.

I think i might buy a new motherboard, but before i do, are there any suggestions i can try ?

Thanks in advance!
 

eismc2

Senior Member
User systemen
Hi and welcome to the forum. If it is possible, could you please give up the exact type of Samsung series 5 ultra book or more info on the spec? Something like Samsung Series 5 Ultra 540U3C - 13.3" or Part Number: NP540U3C-A01UB.
Information about which power supply/adapter used, is beneficial as well.

Normally you should be able to enter the bios by pressing F2 during startup process repeatedly, but I guess you tried that already.

Have you tested the ram for faults with memtest86 or tried booting from an usb stick?

Why do you think you should replace the motherboard? Have you got any indication that you should? Thanks.
 
Bovenaan