1. Welkom op het Hardware.Info Forum

    Hier kun je terecht met al je vragen over computerhardware en consumentenelektronica. Wil je zelf een vraag stellen of deelnemen aan discussies, dan moet je je registreren of inloggen met je Google of Facebook account. Veel plezier op het Hardware.Info Forum!

    Notificatie sluiten

Hardware firewall

Discussie in 'Routers, NAS-apparaten en netwerkapparatuur' gestart door Jorn23, 18 mrt 2013.

  1. Jorn23

    Jorn23 Member

    Sinds:
    7 feb 2013
    Berichten:
    35
    Goedemorgen,

    Graag zou ik willen weten of er hardware firewalls bestaan met ingebouwde WiFi router? Het punt is namelijk dat de hardware firewall mijns inziens (via UTP kabel) aangesloten wordt op de router van de provider. Indien je dan via het WiFi-toegangspunt van de router van de provider verbinding blijft maken heb je nog geen profijt van de extra beveiliging van de hardware firewall, wél als er in de hardware firewall een ingebouwd WiFi-toegangspunt zit waarmee je verbinding kunt maken.
    Zie ik dit goed?

    Zou je wellicht ook een aantal voorbeeld firewalls kunnen laten weten waarin een WiFi router ingebouwd is.

    Ik hoop dat mijn vraag duidelijk is.
    Graag alleen een reactie als je een concreet antwoord kunt geven.

    Alvast bedankt voor de reactie(s).

    Met vriendelijke groet,

    Jorn
     
    Laatst bewerkt: 18 mrt 2013
  2. SCooper

    SCooper Member

    Sinds:
    8 okt 2011
    Berichten:
    31
    Hallo, ik denk dat ik het goed begrijp.

    Een goedkope(re) variant:
    Je zou de wireless in je modem/router van je provider uit moeten zetten, en zo ook de router-functionaliteit. Dan gebruik je het apparaat dus alleen als modem. Dat apparaat verbind je dan met je firewall, vervolgens verbind je een wireless router/accesspoint met je firewall. De WiFi zit dan achter je firewall.

    De opstelling is dan als volgt:
    internet > firewall > accesspoint/wireless router

    Ik weet alleen niet wat voor een firewall je hebt. Als daar al een router in zit, dan heb je genoeg aan een access point. Is het slechts een firewall, dan neem je een wireless router.

    Een duurdere variant:
    Er zijn inderdaad apparaten verkrijgbaar met firewall en accesspoint in 1. Kijk eens naar de Wireless VPN Firewalls van Netgear, of andere fabrikant.
    Je kunt ook kiezen voor alles-in-1, dus inclusief modem. Een voorbeeld is de Netgear UTM9S waar je een ADSL/VDSL module en een wireless module voor kunt kopen. Daarnaast zit er ook een WAN voor een kabel/fiber modem. Dan heb je een modem, firewall en access point in 1 apparaat.
     
  3. Jurgen1994

    Jurgen1994 Senior Member

    Sinds:
    1 sep 2010
    Berichten:
    131
    Heb zelf een Watchguard firewall met access point ingebouw. Ben er zeer tevreden over kan je compleet naar je hand zetten :)
     
  4. mennoboerrigter

    mennoboerrigter Member

    Sinds:
    3 jan 2011
    Berichten:
    60
    Er is maar op 1 punt een firewall nodig (meestal zo dicht mogelijk bij de bron. De modem dus) als daaraan een wireless router word aangesloten sluist die het verkeer door de firewall heen en word het daar "gefilterd". Er zit in bijna elke modem/router wel een firewall ingebouwd.

    Het is ook mogelijk om allerlei dure apparaten te kopen (firewall IPS/IDS of ASA) maar dat is echt niet nodig!
     
  5. Jorn23

    Jorn23 Member

    Sinds:
    7 feb 2013
    Berichten:
    35
    Momenteel zit ik te kijken naar de volgende network security firewall:

    Cisco RV220W Network Security Firewall

    Als ik het goed begrijp zit hier toch een WiFi-router ingebouwd?

    En ik mag toch aannemen dat deze qua beveiliging wat beter is dan een normale thuis-router (aangezien het een Small Business router betreft)?

    Bedankt.

    Groet,

    Jorn
     
    Laatst bewerkt: 20 mrt 2013
  6. Jorn23

    Jorn23 Member

    Sinds:
    7 feb 2013
    Berichten:
    35

    Dat idee heb ik over het algemeen ook. Mijn vader wil echter een betere beveiliging voor een kleine onderneming. De Cisco RV220 Small Business router zal toch over het algemeen een iets betere beveiliging hebben als een normale thuis-router?
     
  7. Jorn23

    Jorn23 Member

    Sinds:
    7 feb 2013
    Berichten:
    35
    Mag ik het model/type# van je firewall (heeft deze ook een ingebouwde WiFi)?
    Betreft dit een hardware firewall?
     
  8. Jurgen1994

    Jurgen1994 Senior Member

    Sinds:
    1 sep 2010
    Berichten:
    131
  9. Jorn23

    Jorn23 Member

    Sinds:
    7 feb 2013
    Berichten:
    35
    Nog een vraagje:

    Hoe gaat het in z'n werk met updaten? Ik neem toch aan dat er software draait op een hardware firewall. Indien er niet regelmatig updates uitgegeven worden door de fabrikant is de additionele beveiliging en daarmee de meerwaarde van een hardware firewall toch ook weg?

    Graag meer info van iemand die hiermee bekend is.
     
  10. mennoboerrigter

    mennoboerrigter Member

    Sinds:
    3 jan 2011
    Berichten:
    60
    Het is mij nu duidelijk dat het over een bedrijfs netwerkje hebt. Als bedrijf kan je niet slordig zijn met security. Ik ben een GROOT Cisco fan (niet linksys). Cisco levert regelmatig nieuwe firmware. Maar de firewall moet je echt zelf configureren. Dus of het veilig is of niet ligt (groten)deels aan jezelf.

    Ik werk veel met Cisco routers maar dan wel het professionele spul. Die routers zijn echt geweldig je kunt er echt alles mee en precies hoe jij dat wilt. Het grote nadeel is dat het duur is. Ook moet je diepgaande kennis hebben om zo'n ding goed te configureren maar als het staat dan heb je ook wat!

    Ik heb geen ervaring met Cisco RV220W Network Security Firewall. Ik heb het idee dat dit wat toegankelijker is voor de "gewone consument". Het is trouwens niet nodig om een firewall IN de router te hebben. Deze setup moet ook kunnen werken ookal is het natte vingerwerk aangezien ik de eisen/wensen en de situatie niet precies weet:

    Wan>modem>firewall>(wireless router)>lan

    Ook is het handig om het budget te weten en is het handig om een consultant in te huren als je de security echt serieus neemt.

    Ik weet dat dit niet echt een concreet antwoord is op jouw vraag maar hoop je toch een beetje te hebben geholpen.

    Groet, Menno
     
  11. Jorn23

    Jorn23 Member

    Sinds:
    7 feb 2013
    Berichten:
    35
    Menno,

    Bedankt voor je informatie.

    Het gaat om een kleine onderneming, maar het betreft het netwerk thuis. Cisco geeft aan de RV220 aanzienlijk beter is qua beveiliging dan een normale thuis-router. Dit lijkt me wel kloppen, want het is niet voor niets een Small Business product.
    Het klopt wat je zegt: het is een eenvoudiger aan te sluiten firewall, maar voor een klein bedrijfje waarvoor thuis enkele zakelijke activiteiten (o.a. betalingen) gedaan worden op een laptop lijkt me dit toch een prima optie?

    Jij bedoelt waarschijnlijk firewalls waar je ook licenties bij koopt etc.? Deze heeft trouwens redelijke beveiligingsnormen geloof ik hoor...
     
  12. mennoboerrigter

    mennoboerrigter Member

    Sinds:
    3 jan 2011
    Berichten:
    60
    Ik denk dat je goed zit met de betreffende Router. Security komt nooit door 1 aspect zoals een firewall. Ik denk dat deze router een geavanceerder interface heeft dan je huidige router of het daadwerkelijk veiliger is, dat weet ik niet zeker. Hij zal ongetwijfeld wel sneller/stabieler en mooier zijn dan je huidige router er van uitgaand dat je de router gebruikt die je kreeg bij je abonnement.

    Om terug te komen op mijn verhaal hierboven: Zelf heb ik een router (cisco 2811) en daarin heb ik zelf een firewall geconfigureerd. Eerst heb alles dichtgezet vervolgens heb ik gedefinieerd met acceslists wat ik toesta en aan welke criteria het antwoord moet voldoen voordat het mijn netwerk in kan komen.

    Ik weet niet hoe de firewall in jouw router er gaat uitzien maar die zul je wel kunnen instellen middels een gebruikersvriendelijke grafische interface. Hij zal zeker voldoen voor een klein bedrijfje.

    Het zou mooi zijn als je het bedrijfsnetwerkje (laptop) zou scheiden van je prive netwerk.

    Een firewall is geen virusscan het is daarom ook niet noodzakelijk om elke dag/week een nieuwe update te krijgen
     
    Laatst bewerkt: 20 mrt 2013
  13. SCooper

    SCooper Member

    Sinds:
    8 okt 2011
    Berichten:
    31
    De licenties waar je het over hebt zijn niet voor de firewall zelf, want een firewall is slechts een set van regels die je zelf kunt instellen wat je wel en niet toestaat. Virussen, spyware and spam komt er nog steeds gewoon doorheen. Hiervoor dien je dus een anti-virusprogramma te installeren op je pc.
    Cisco, net zoals andere fabrikanten van firewalls, biedt extra beveiling aan voor haar firewalls. Cisco heeft ProtectLink Security dat je tegen betaling ook beschermt tegen de eerder genoemde gevaren.
     
  14. Jorn23

    Jorn23 Member

    Sinds:
    7 feb 2013
    Berichten:
    35
    Ok, ook weer wat duidelijker.
    In de genoemde firewall (RV220) zit trouwens ProtectLink Security, wat je noemde.

    En in principe kun je op thuis-routers ook poorten blocken toch? Dan zal dat op deze ook zeker kunnen. Wat kan ik dan bij zo'n duurdere firewall nog extra instellen? En dan ga je zeker richting de 1000 euro of iets dergelijks of niet? Die Small Business Security Firewall die ik noemde is 250 euro.

    Kan iemand mij informeren wat ik moet blocken? Ik weet dat dit per situatie verschilt, maar is dit uit te leggen, zodat ik er meer bekend mee wordt?

    Nogmaals bedankt.
     
  15. SCooper

    SCooper Member

    Sinds:
    8 okt 2011
    Berichten:
    31
    Bij de duurdere zakelijke hardware kun je bijvoorbeeld per poort (computer) je regels instellen voor verkeer. Daarnaast kun je bijvoorbeeld denken aan zaken als VPN, uitgebreidere Quality over Service en Access Control, VLAN, content filter en noem maar op. Hoe duurder, des te meer functionaliteit en te configureren meestal. Ook is de zakelijke hardware vaak sneller en stabieler. Je moet echter wel eerst goed nadenken wat je wel en niet nodig hebt en zult gaan gebruiken. Anders is het pure geldverspilling om 1000 euro uit te geven terwijl je niet meer gebruikt dan wat een router van 50 euro te bieden heeft.

    Qua firewall en blocken: je staat alleen dat toe wat je wilt gaan gebruiken. Dit kun je echter ook op de computer zelf doen. Het voordeel van een hardware firewall is dat je dan het dataverkeer kan controleren voordat het in je netwerk komt. Een goedkope router heeft ook gewoon een firewall. Een firewall is niets meer dan een set van regels over wat je wel en niet toe staat. Op basis daarvan wordt verkeer toegelaten of afgewezen. Het kan dus bepaalde data of website blokkeren. Daarnaast kun je ervoor kiezen bepaalde poorten door te laten verwijzen naar een bepaalde pc zodat ze ook van buiten het netwerk te benaderen zijn. Het werkt allemaal op dezelfde manier als bij een consumenten router, je hebt alleen meer flexibiliteit en detail qua configuratie bij een zakelijke router.
     
  16. Jorn23

    Jorn23 Member

    Sinds:
    7 feb 2013
    Berichten:
    35
    Nogmaals bedankt voor weer een reactie.

    Zoals ik al aangaf ben ik me er wel degelijk van bewust dat er niet een standaard manier is en elke situatie verschilt qua configureren van een firewall.

    Echter, ik ben redelijk breed georiënteerd op het gebied van computers, al heb ik niet de programmeerkennis, etc.
    Een firewall configureren heb ik, zoals je gemerkt zult hebben, nog niet eerder gedaan (poorten instellen enzo.), maar ik ben er wel altijd voor in om er meer over te weten te komen, over iets nieuws.
    Daarom: kun je (of iemand anders) me enigszins aangeven welke poorten ik kan blocken en welke openhouden? Het gaat puur om de 'gebruikelijke' functies (internet, e-mail), verder eigenlijk weinig.
    Ik zou zo zeggen dat ik heel veel kan blocken, of niet?

    Wederom bedankt.

    Groet,

    Jorn
     
  17. mennoboerrigter

    mennoboerrigter Member

    Sinds:
    3 jan 2011
    Berichten:
    60
    Goede avond,

    Ik heb het idee dat je voorbeelden wilt zien van firewall regels.

    R1(config)#ip inspect name MYSITE tcp
    R1(config)#ip inspect name MYSITE udp

    R1(config)# access-list 102 permit tcp any 209.165.201.1 0.0.0.0 eq 80
    R1(config)# access-list 102 permit tcp any 209.165.201.2 0.0.0.0 eq smtp
    R1(config)# access-list 102 permit icmp any any echo-reply
    R1(config)# access-list 102 permit icmp any any unreachable
    R1(config)# access-list 102 permit icmp any any administratively-prohibited
    R1(config)# access-list 102 permit icmp any any packet-too-big
    R1(config)# access-list 102 permit icmp any any echo
    R1(config)# access-list 102 permit icmp any any time-exceeded
    R1(config)# access-list 102 deny ip any any

    Dit is een set regels die je kunt gebruiken om je web server (deels) te beveiligen. Hier staat dat webverkeer en mailverkeer is toegestaan en voor de rest NIETS.
    Deze accesslist zet je op de interface waar het verkeer van buiten naar binnen komt (dit geval de serial).

    R1(config)# interface S0/0/0
    R1(config-if)#ip access-group 102 in

    R1(config)# interface Fa0/0
    R1(config-if)#ip inspect MYSITE in

    S staat voor serial en deze fugeerd als WAN verbinding
    fa staat voor fast ethernet en dit is de aansluiting waar de web/mailserver staat.

    Dit is overigens geconfigureerd op een cisco 2811 in een test omgeving van een netwerk met een web en mailserver in de DMZ .
    Dit is alleen een voorbeeld en dit moet je niet overnemen in jouw beveiliging want dit is niet waterdicht. En elke situatie is anders dus elke situatie vereist zijn eigen firewall.
     
    Laatst bewerkt: 22 mrt 2013
  18. SCooper

    SCooper Member

    Sinds:
    8 okt 2011
    Berichten:
    31
    Ik kan je niet vertellen wat je open moet doen en niet. Dat hangt volledig af van je behoeften. Wil je een mailserver runnen, dan moet je de betreffende poorten daarvoor openen om mails te kunnen versturen en ontvangen, zoals SMTP, POP3, IMPAP3. Of je wilt FTP, HTTP, Telnet, SSL, IRC, en noem maar op.
    Al deze en meer applicaties hebben een standaard poort. Je hoeft je echter geen zorgen te maken voor alle poorten/applicaties. Gebruik je een applicatie niet dan kan deze ook niet misbruikt worden. Het is niets anders dan een router thuis, daarin heb je ook niet alles dicht staan?
    Zo'n zakelijke firewall biedt alleen veel meer flexibiliteit zodat je een veel beter beheer hebt over de clients. Zo kun je bv groepen gebruikers beheren, zodat bijvoorbeeld een groep niet op yahoo messenger kan, maar een andere juist wel. Ik weet niet of dit van toepassing is? Als je alleen internet/email wilt hebben (dus de meeste thuissituaties) dan is zo'n zakelijke router waarschijnlijk niet nodig.
     
  19. RazorBlade

    RazorBlade Senior Member

    Sinds:
    15 jul 2005
    Berichten:
    847
    Als het voor een standaard thuis situatie is waarbij er in huis geen servers zijn die van buitenaf te benaderen zijn dan volstaat een eenvoudige firewall omdat je dan gewoon alle porten dicht kan laten. Alleen verkeer dat van binnen uit wordt geinitieerd kan dan weer terug gestuurd worden.

    Los daar van kan je ook een firewall hebben die inderdaad al het verkeer dat binnenkomt scant op malware of die een lijst bijhoud van foute websites. Hier zit inderdaad een abbonement aan gekoppeld. Als je verstandig bent en je trapt niet overal in dan is een dergelijke firewall niet echt nodig. Een goede virusscanner zou dan minstens net zo goed werken.

    De beste beveiliging is overigens om al je software up to date te houden (niet alleen Windows). Sommige software heeft overigens op veiligheidsgebied een twijfelachtige reputatie. Denk daarbij aan Adobe flash en Java.
     
  20. Jorn23

    Jorn23 Member

    Sinds:
    7 feb 2013
    Berichten:
    35
    Ok, thanks.

    Kan en WIL iemand mij t.z.t. gidsen m.b.t. het instellen van poorten die gebruikt mogen worden en dus toegestaan door de firewall?
    Het gaat puur om surfen en e-mail. Dus ik neem aan dat wanneer je bijvoorbeeld o.a. poort 110, 25 en 80 (is toch internet?) en verder welke je nog meer nodig hebt voor normaal gebruik openzet je dan ongeveer aan de slag kunt? Vervolgens blockt ie toch automatisch de overige poorten, zei iemand?
    Dat lijkt me dan toch wel een extra beveiliging?

    Het is puur om m'n pa gerust te stellen, dus als het dan net wat beter is dan 'normaal' is het OK. Mijn mening is ook altijd zoals jullie al aangaven: geen 'vreemde' content (e-mail, websites, etc.) openen, een goed internet security software pakket, alle software telkens goed updaten en natuurlijk altijd je verstand gebruiken met wat je doet en invult, maar ik krijg 't er maar niet in dat dat de enige remedie is.

    Graag hoor ik nog van jullie en nogmaals fijn dat jullie zo bereidwillig zijn.

    Groet,

    Jorn